[Nml-wg] Example topology of Automated GOLE

Roman Łapacz romradz at man.poznan.pl
Thu Feb 16 07:00:31 EST 2012


an update is attached. Two changes:
- use of xCard for the contact element (rfc6351)
- I was thinking a bit about "next" vs "connectedTo" (I wouldn't like to 
have the situation when we there are different attribute values which 
mean the same; let's keep the set of xml/nml elements and their 
attribute values as small as possible). There is a solution which avoid 
the conflict of existing these two values in the NML world. I propose to 
use a namespae for type attribute in the relation element. In  the case 
of  topology for NSI we could have nml-nsi:type which ensures that the 
value "connectedTo" is known and accepted by application parsers.


W dniu 2012-02-15 13:41, Roman Łapacz pisze:
> W dniu 2012-02-15 13:20, Jeroen van der Ham pisze:
>> On 15 Feb 2012, at 12:31, Roman Łapacz wrote:
>>>> On to the comments for your description:
>>>> - You're using<nml:relation type="next">   to describe connections, 
>>>> this should be<nml:relation type="connectedTo">.
>>> I proposed "next" because it was already used in the framework for 
>>> circuit monitoring. I'm hesitating to introduce an other name which 
>>> means the same (1. as I wrote I try to limit new names; 2. use of 
>>> new name would be incompatible or inconsistent with that solution 
>>> for circuit monitoring).  On the other hand, "connectedTo" is 
>>> already used by NSI so I understand that some continuation is 
>>> welcome. If you think that it's really important to keep 
>>> "connectedTo" then I'm fine.
>> We're already saying that an nml-nsi:STP is equivalent to an nml:Port 
>> with some added behavior. I don't really see any reason why 
>> connectedTo would not work in this case.
> Just to clarify, I propose nml-nsi:port, not nml-nsi:STP (port in the 
> nml-nsi namespace would be STP).  "connectedTo" would work, no doubt, 
> but the question is: should we use this if we already used "next" in 
> circuit monitoring (and both mean the same).
>>>> - We don't have an nml:contact object at the moment, but it seems 
>>>> that we may indeed need one. However, defining the contact methods 
>>>> should perhaps be done using some other appropriate (standard) schema.
>>> I'll try to find something. Any suggestions are welcome.
>> There's a FOAF namespace in RDF which describes similar things about 
>> a person. However, it's not really a standard I think.
>> There's also the vCard standard, for which there is (I think) both an 
>> RDF and XML notation.
> yes, vCard was my first candidate as well
> http://tools.ietf.org/html/rfc6351
> Roman
>> Jeroen.
> _______________________________________________
> nml-wg mailing list
> nml-wg at ogf.org
> https://www.ogf.org/mailman/listinfo/nml-wg

-------------- next part --------------
A non-text attachment was scrubbed...
Name: AutoGOLE-Topo-2012-01-25-NML_example_v2.xml
Type: text/xml
Size: 7932 bytes
Desc: not available
URL: <http://www.ogf.org/pipermail/nml-wg/attachments/20120216/b218f27a/attachment.xml>

More information about the nml-wg mailing list